chispa1707 (chispa1707) wrote,
chispa1707
chispa1707

Освоил новый инструмент в Эксель

Выглядит так:
=ИНДЕКС(Лист1!$C$1:$C$99;ПОИСКПОЗ(ЛОЖЬ;ЕНД(ПОИСКПОЗ("*"&Лист1!$A$1:$A$99&"*";A4;));))

Позволяет в ячейке с довольно большим текстом найти город, сверить его со списком и оставить в нужном столбце название, координаты и все, что понадобится.
То, на что я планировал потратить много-много-много дней, машина способна сделать сама за пару часов.

Проблема в наличии в списке вот таких городов:

Лам, Кам, Очер, До, Вер, Мор, Дан, Дно, Бра, Де, Хон, Нем...

То есть, если в тексте есть слово "данайцы", то выпадет город Дан.
А если в ячейке есть "сКОТОВОдство", то выпадет город КОТОВО.
Ладно, лиха беда начало...

ЗЫ: и придется-таки вводить трехбуквенные географические индексы.
Иначе на все штаты и области не хватит. А надо.
Subscribe
  • Post a new comment

    Error

    Anonymous comments are disabled in this journal

    default userpic

    Your reply will be screened

    Your IP address will be recorded 

  • 14 comments